Un error de ocho años de antiguedad en Linux

Dos investigadores han descubierto un error en el kernel Linux que lleva nada menos que desde 2001 en las distintas versiones de estos desarrollos y que por lo visto es muy fácil de aprovechar para ganar privilegios de control sobre una máquina con este sistema operativo instalado.

Julien Tinnes, uno de los encargados del estudio, ha revelado en su blog los detalles del descubrimiento, que afecta a la forma en la que Linux trata algunos protocolos y los punteros a NULL que pueden darse en ciertas situaciones.

Ese tratamiento provoca que un atacante pueda explotar la vulnerabilidad muy fácilmente, y lo extraño es que los núcleos 2.4 y 2.6 desde mayo de 2001 están afectadas. Como indican en MuyComputer, el fallo ha sido ya corregido por Linus Tovalds, y pronto estará disponible en los sistemas de actualización de las distintas distribuciones disponibles en el mercado.

enlace

MuyComputer

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: