Exploit activo para vulnerabilidad MS08-021 (GDI)

Se ha reportado un exploit activo para una vulnerabilidad recientemente solucionada en uno de los últimos boletines de Microsoft (abril 2008). Debido a la naturaleza del problema, aconsejamos a quienes no lo hayan hecho aún, actualizar sus sistemas a la brevedad posible.

El problema, un desbordamiento de búfer, ocurre en la interfase de dispositivo gráfico de Microsoft Windows (GDI), y está relacionada con archivos Windows Metafile (WMF) y Enhanced Metafile (EMF), formatos de imágenes utilizados principalmente por el sistema operativo Windows.

Esta vulnerabilidad permite la ejecución remota de código, y ya existe al menos un exploit público, un archivo .JPG que descarga otro con extensión .GIF, que en realidad es un troyano. Cuando es abierto, utiliza el Internet Explorer (iexplore.exe), para intentar conectarse a un sitio en China, supuestamente para descargar otros malwares.

Aunque no hay muchos reportes de este exploit, e inclusive las muestras obtenidas parecen no funcionar correctamente, en realidad no es aventurado decir que puede ser cuestión de horas que el mismo sea mejorado, y utilizado por alguna clase de código malicioso para propagarse masivamente.

Tenga en cuenta que el exploit puede activarse con solo visualizar una página Web, ya que el Internet Explorer, en su configuración por defecto, como resultado de esa visualización, puede iniciar automáticamente el Windows Picture y el Fax Viewer, que son vectores conocidos de ataque, desde donde se iniciaría la ejecución de un código remoto.

La instalación de la actualización de seguridad MS08-021 impide la acción de esta clase de exploits, protegiendo al usuario de esta amenaza.

El filtrado de extensiones WMF o EMF, así como el tipo MIME “application/x-msMetafile”, no bloquean todos los vectores de ataque conocidos para esta vulnerabilidad (los tipos MIME controlan los tipos de archivos multimedia que son compatibles con el sistema).

Referencias:

Vulnerability Note VU#632963
Microsoft GDI buffer overflow vulnerability
http://www.kb.cert.org/vuls/id/632963

Microsoft Security Bulletin MS08-021 – Critical
Vulnerabilities in GDI Could Allow Remote Code Execution (948590)
http://www.microsoft.com/technet/security/bulletin/ms08-021.mspx

Ocho boletines de seguridad, cinco parches críticos
http://www.vsantivirus.com/ms08-abr.htm

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: