Alerta sobre nueva vulnerabilidad en QuickTime

Se anunciaron hoy nuevas vulnerabilidades en QuickTime que afectan las versiones para Windows, justo cuando apenas hace una semana, Apple había solucionado en dicho software un importante fallo, el cuál fue de conocimiento público por casi un mes antes de ser arreglado.

Los detalles publicados junto a una prueba de concepto, mencionan vulnerabilidades en cinco funciones de un control ActiveX de QuickTime (QTPlugin.ocx).

El ataque funciona incluso con la nueva versión de QuickTime (la 7.4.1), la cuál fue publicada para solucionar un problema en el protocolo RTSP (Real Time Streaming Protocol), utilizado para realizar streaming, técnica de transmisión unidireccional de contenidos de video y audio a través de Internet.

Debido a que la nueva vulnerabilidad está relacionada con un control ActiveX, la tecnología de Microsoft ampliamente utilizada en Internet Explorer, los usuarios de Windows son quienes corren más peligro si utilizan QuickTime como visor de películas.

Un ataque con un código malicioso puede ser cuestión de horas, luego de la aparición de la prueba de concepto y de la revelación de los detalles de las vulnerabilidades.

Los puntos de ataque más probables, son sitios de redes sociales como MySpace.com, donde múltiples páginas utilizan controles ActiveX vulnerables.

Además de ello, y según reportábamos hace una semana, MySpace, Yahoo! Music y otros, usan otros controles ActiveX vulnerables. Los controles utilizados por Facebook y MySpace, por ejemplo, pueden ser fácilmente comprometidos por un atacante para la descarga de código malicioso en la computadora de la víctima.

Estos controles son utilizados por los usuarios de MySpace y FaceBook para subir imágenes a sus páginas.

Si sumamos ello a la nueva vulnerabilidad en el control ActiveX de QuickTime, puede presentarse un escenario crítico para muchos usuarios que navegan por estos sitios. Tanto como para que el US-CERT (Computer Emergency Readiness Team), esté recomendando desactivar completamente los controles ActiveX.

Apple no ha emitido opinión respecto a la nueva vulnerabilidad en QuickTime.

Por el momento, recomendamos desinstalar dicha aplicación.

Referencias:

QuickTime <= 7.4.1 QTPlugin.ocx Multiple Remote Stack Overflow
http://seclists.org/fulldisclosure/2008/Feb/0304.html

Vulnerability Note VU#101676
Yahoo! Music Jukebox YMP Datagrid ActiveX control stack buffer overflows
http://www.kb.cert.org/vuls/id/101676

Securing Your Web Browser
http://www.us-cert.gov/reading_room/securing_browser/browser_security.html

Relacionados:

Nueva vulnerabilidad en QuickTime y el protocolo RTSP
http://www.vsantivirus.com/vul-quicktime-rtsp-100108.htm

MySpace, Yahoo! Music y otros, usan ActiveX vulnerables
http://www.vsantivirus.com/vul-activex-030208.htm

Configuración personalizada para hacer más seguro el IE
http://www.vsantivirus.com/faq-sitios-confianza.htm

via vsantivirus

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: